Email endpoint can't send email in own vps, forgot password didn't run


I’ve made the server in my vps, has been successful for dashboard, data bucket and run perfectly, thanks for
but there is one problem that is when forgot password to login, I try to reset password, but no email sent, I try also end point email also can not send email.
for additional information I use smtp gmail server in smtp server thinger setting.
is there anybody who can help me


We have some issues regarding SMTP compatibility in local deployments. We are working on them. Do you have access to other SMTP server?


Hi, same here.
Use own hosted VPS, and cannot send email endpoint.
Any update regarding to this @Delta_Electronics?


Hi all,
Just investigate in the server log and got this messages regarding email endpoint :
2018-01-29T00:24:27.546713 info [Thing Connection] [soketpintar2@soketpintar] Received Keep Alive!
2018-01-29T00:25:27.876779 info [Thing Connection] [soketpintar2@soketpintar] Received Keep Alive!
2018-01-29T00:25:28.206236 info [Thing Connection] [soketpintar2@soketpintar] Calling Endpoint: hi_temp
2018-01-29T00:25:28.206626 error [Email Interface] Cannot send email to ‘’. No email interface initialized

Where can i get email interface to configure it?
Any hint @alvarolb ?


sorry long time do not reply, I’ve tried using another smtp server that we manage ourselves, but still can not send email. I’ve also try unsecured connection still can not, please help me alvaro, so the thinger server can run on our own vps server.


Can you post your Configurator file? I have a server running in an azure vm and my smtp E-Mail Server is working without a problem.


where is the con

figurator file?, is it config.json? that in var/snap/thinger-maker-server/common/config.json?


Yes this is the config file:

I thing domain should be “”.
Host should be ""
and sercure should be “true”

Does it work?

Best regards,


Did you tried with domain as, and username m.januar.susanto ?


Hi, have you been able to solve your problem? I think I’m in a similar situation
I can not configure the mail, or hotmail, or gmail, probe with several ports, I’m missing something.
Is there any place where you keep the log? to see what is happening?
I do not think it’s the sketch, since I’m with a basic example.
Thank you