Email endpoint can't send email in own vps, forgot password didn't run


#21

No, it should work! Enable the logs and check them. I recommend you to enable log level trace.


#22

Hi @astonix, we have updated the final version of the snap package. There was a problem accessing the server over SSL in the BETA version. Now it should be fixed, along with the other mentioned features… Please, give us some feedback :wink:


#23

Hi @alvarolb
Now, our thinger platform can be accessed via web browser with https connection, thanks for the update to 1.5.19 version.
The SMTP configuration still cannot be implemented, thinger application is always failed when i tried to restart. This is my SMTP config :

“email” : {
“type” : “smtp”,
“domain” : “gmail.com”,
“sender” : “astonix”,
“smtp” : {
“host” : “smtp.gmail.com”,
“port” : “465”,
“username” : "astonix@gmail.com",
“password” : “my_gmail_password”,
“secure” : true
}
}

The log file when i restarted thinger is below :

systemd[1]: snap.thinger-maker-server.thingerd.service: Main process exited, code=dumped, status=6/ABRT
systemd[1]: snap.thinger-maker-server.thingerd.service: Unit entered failed state.
systemd[1]: snap.thinger-maker-server.thingerd.service: Failed with result ‘core-dump’.
systemd[1]: snap.thinger-maker-server.thingerd.service: Service hold-off time over, scheduling restart.
systemd[1]: Stopped Service for snap application thinger-maker-server.thingerd.
systemd[1]: snap.thinger-maker-server.thingerd.service: Start request repeated too quickly.
systemd[1]: Failed to start Service for snap application thinger-maker-server.thingerd.

Does anyone had the same issue like this?


#24

Hi, check that your JSON is well formed (you can use online tool validators). We well try to improve the error reporting in such cases. If your server is failing on every start, it seems to be a configuration problem (i.e., malformed JSON document).


#25

Hello, I am using a local Thinger.IO server and our own Mail server, Within our network SMTP Authentication is not necessary. I tried leaving password blank, and changing secure to false. but it fails to work. The SMTP log files say that it is being rejected during the Authentication Process.

Thank you for your help