Unable to start Thinger server


#1

Trying to start with this command:
sudo service snap.thinger-maker-server.thingerd start

sudo service snap.thinger-maker-server.thingerd status
On Status getting:

Getting following error:
snap.thinger-maker-server.thingerd.service - Service for snap application thinger-maker-server.thingerd
Loaded: loaded (/etc/systemd/system/snap.thinger-maker-server.thingerd.service; enabled; vendor preset: enabled)
Active: inactive (dead) (Result: core-dump) since Fri 2018-04-20 22:28:38 IST; 10s ago
Process: 3759 ExecStart=/usr/bin/snap run thinger-maker-server.thingerd (code=exited, status=0/SUCCESS)
Main PID: 3771 (code=dumped, signal=ABRT)

Apr 20 22:28:37 vishu systemd[1]: snap.thinger-maker-server.thingerd.service: Unit entered failed state.
Apr 20 22:28:37 vishu systemd[1]: snap.thinger-maker-server.thingerd.service: Failed with result ‘core-dump’.
Apr 20 22:28:38 vishu systemd[1]: snap.thinger-maker-server.thingerd.service: Service hold-off time over, scheduling restart.
Apr 20 22:28:38 vishu systemd[1]: Stopped Service for snap application thinger-maker-server.thingerd.
Apr 20 22:28:38 vishu systemd[1]: snap.thinger-maker-server.thingerd.service: Start request repeated too quickly.
Apr 20 22:28:38 vishu systemd[1]: Failed to start Service for snap application thinger-maker-server.thingerd.
Apr 20 22:28:41 vishu systemd[1]: Stopped Service for snap application thinger-maker-server.thingerd.


#2

Hi, is it a clean install? or just happened after the recent upgrade? Try to place the default config file (as stated in docs) to see if it is a problem related with the config. Hope it helps!


#3

follows the step as defined.
PLease find my confilg file:

{

  "ssl" : {
    "ssl_certificate" : "certificates/server.crt",
    "ssl_certificate_key" : "certificates/server.key",
    "tmp_dh_file" : "certificates/dh2048.pem",
    "ssl_ciphers" : "ECDHE-RSA-AES256-GCM-SHA384:ECDHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-SHA384:ECDHE-RSA-AES128-SHA256:ECDHE-RSA-AES256-SHA:ECDHE-RSA-AES128-SHA:DHE-RSA-AES256-SHA256:DHE-RSA-AES128-SHA256:DHE-RSA-AES256-SHA:DHE-RSA-AES128-SHA:ECDHE-RSA-DES-CBC3-SHA:EDH-RSA-DES-CBC3-SHA:AES256-GCM-SHA384:AES128-GCM-SHA256:AES256-SHA256:AES128-SHA256:AES256-SHA:AES128-SHA:DES-CBC3-SHA:HIGH:!aNULL:!eNULL:!EXPORT:!DES:!MD5:!PSK:!RC4",
    "ssl_prefer_server_ciphers" : true
  },

  "http_server" : {
    "address" : "192.68.0.1",
    "port" : "80",
    "ssl_port" : "443",
    "hosts" : [
      {
        "host": "*",
        "type": "rest"
       },

        "cors": {
          "enabled" : true
        },
        "web_fallback" : {
          "enabled" : true,
          "root": "${SNAP}/console"
        }
      
    ]
  },

  "thing_server" : {
    "address" : "189.68.72.2",
    "port" : "25200",
    "ssl_port" : "25202"
  },

  "database" : {
    "type" : "mongodb",
    "mongodb" : {
      "host" : "localhost",
      "database" : "thinger"
    }
  },

  "buckets" : {
    "storage" : {
      "type" : "mongodb",
      "mongodb" : {
        "host" : "localhost",
        "database" : "thinger_data",
        "table" : "buckets_data"
      }
    },
    "export" : {
      "type" : "filesystem",
      "filesystem" : {
        "export_path": "exports"
      }
    }
  },

  "util" : {
    "maxmind_database" : "data/GeoLite2-City.mmdb"
  },

  "log" : {
    "enabled" : false,
    "level" : "info",
    "output" : {
      "file" : {
        "enabled" : true,
        "flush" : true,
        "log_path" : "logs"
      },
      "clog" : {
        "enabled" : false
      }
    }
  },

  "accounts" : {
    "invalid_usernames" : [],
    "invalid_email_domains" : [],
    "required_email_domains" : [],
    "require_email_verification": false,
    "min_password_length" : 6,
    "limits" : {
      "devices" : {
        "max_count" : -1
      },
      "buckets" : {
        "max_count" : -1,
        "min_interval" : -1
      },
      "endpoints" : {
        "max_count" : -1,
        "min_interval" : -1
      },
      "dashboards" : {
        "max_count" : -1
      },
      "tokens" : {
        "max_count" : -1
      }
    }
  }
}

#4

Hi, this is not the latest default config file as stated in the docs. And also, the address 192.68.0.1 not seems to be correct, is it? is it the address of your server? I suggest you to keep the default value 0.0.0.0 to listen on all network interfaces.


#5

And… this JSON is not valid… take a look to the “cors” and “web_fallback”.