Unable to connect into own deploy server


#1

Dear gurus, recently I’m deployed my own thinger.io server by using VirtualBox software. Everything seems fine, and I’d it tried to establish connection with my ESP32 via WiFi (local network), result is perfect! Meanwhile, when i tried to connect it from outside, it does not response at all. I even tried to use a GSM module with my ESP32, it just could not connect into my server (but can be connect to iot.thinger.io server).

Does anyone experience this before? Creating a virtual server by using VM virtualBox?? Any port forwarding should i do with my router? We need a guide for this :frowning:


#2

The ports 443 (https), 80 (http), 25200 (thinger connection), and 25202 (thinger secure connection), should be accesible from thinger clients (devices or computers) to thinger server, if you have a router between they, of course you need to do a port forwarding.

Remember if it is working on a local environment (with clients in the same network segment), and doesn’t work in a different network configuration, the issue is not in the platform, it is in the network configuration.

You need to verify if your router has a public IP address at WAN side, and set up the port forwarding to server’s local ip address, the server’s address for clients outside your local network will be your router’s public IP address.


#3

Thanks ega!! Then should I forward each specific ports (443, 80, 25200, 25202) from my router settings to the target server LAN IP address? Example, my server LAN IP address is 192.168.1.103…so in my router port forward settings:

  • WAN Port: 443 , LAN Port: 443, Target IP : 192.168.1.103
  • WAN Port: 80, LAN Port: 80, Target IP : 192.168.1.103
  • WAN Port: 25200, LAN Port: 25200, Target IP : 192.168.1.103
  • WAN Port: 25202, LAN Port: 25202, Target IP : 192.168.1.103

Is that correct?
Thank you for helping! :slight_smile:


#4

Yes, it should work, but remember that the router must have a public IP address on its WAN side, this depends exclusively on the ISP, for example, my router does not have a public IP address.