[SOLVED] Error 404 with Bucket API, downloading an export


i’m currently working on an API integration with HTTP Requests and trying to download a Bucket Export. I am getting always ‘Error 404 not found’.

Other API calls like getting the devicelist from a user is working. I can list my bucket exports too. Everything i tried works except downloading a specific bucket export.

Is this an already known issue or do i have to make something specific within this call?

Thanks in advance!


i found that my try to download the Bucket Export was not successfull with the command “ReadBucketExport” from Swagger UI. I solved it with getting the url via “ListBucketExports” from my specific Bucket Export and downloading the file with a http get-request.

Maybe this is the correct way how to do this and i just misunderstood the documentation.

However it works now and i’m happy! :slight_smile:

Hi @drempelAT,

your approach is fine for a general purpose integration :wink:

The ReadBucket export will only work on private instances where exports are keep locally. In the community instance, all exports are uploaded to Amazon S3, hence the server throws a 404.