[SOLVED] Arduino Uno + ENC28J60 Ethernet shield: device not connecting


#1

Hi I’m new to thinger. I’m trying to connect my arduino with ENC28J60 ethernet shield on my account. It worked once, but then it suddenly stopped on its own. I tried to re-upload the same code but I didn’t manage to get it to work again.

For the source code, I was testing the example that came with the library and I didn’t change anything 'cept for the credentials needed for the connection to be established. What’s the problem?


#2

Hi! did you tried to enable the debug output to see what is happening?

http://docs.thinger.io/arduino/#coding-enabling-debug-output


#3

Hello. I tried it in another machine and it worked alright. It seems that my anti-virus app blocks some of the network traffic that makes the arduino unable to connect to the internet properly. Anyway thank you for replying.


#4

Uhm :confused: the Arduino is completely independent of your PC, as it does not require the PC for connecting to the Internet. What do you mean when you say that you have tried in a different machine?