Selfhosted: Problem with endpoints not appearing in ui


#1

Hi!

I have a self-hosted Thinger.io and I have imported the custom endpoints as described here:
https://github.com/thinger-io/Server-Endpoints

But they are not avaliable in the Web UI. I have also tried restarting the service and the server.

I have checked the mongoDB and I find the items in the endpoints-templates collection.

Any ideas?

Thank you,
Morten Lund


#2

Hi, I have tested the import script in a default installation with Ubuntu server, and everything seems to be ok (without any restart). Did you changed the default thinger database name?


#3

No, i am using the raspberry pi image purchased from the shop! No changes :slight_smile:
I used a mongodb explorer and checked to see that the items was imported.

I had to manually import the items though since there is no mongoimport function avaliable in the Ubuntu Core distro.
Had to install classic and apt-get mongodb using that and then manually do the same as the import script did.
Wasted some time figuring out how to do that :slight_smile:

I also checked the web request using the browser inspector and the request for the endpoint templates just returns an empty array :slight_smile:

Morten


#4

I also checked that there was only to dbs avaliable on the mongoserver. thinger and thinger_data :slight_smile:
Anything else i can do to verify the correctness? :slight_smile:


#5

Hi, make sure that the collection is called endpoints_templates and not endpoints-templates.


#6

You where of course correct and I had overlooked the underscore…
I thought it was correct as I assumed the collection was allready in the db before the import and that I had only added to it.

Thank you for your help!

Morten


#7

Nice it worked!