Publishing a dashboard - bucket error?


#1

Hi all,

I have a couple of esp8266s publishing temp/humidity/dewpoint/heatindex information to a dashboard and two buckets.

The idea being that I can see the current data straight from the devices - and have a chart for each unit showing a 2 hour history. Works perfectly in the admin/editor mode.

When I publish this dashboard, the live data from the devices shows as expected, but the dashboard shows me two “Bucket Error - bucket is not available!” errors. I have disabled/enabled the buckets - and toggled public on/off for the dashboard - but still no luck. What do I need to do?

https://console.thinger.io/#/dashboard/Demo?authorization=eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJqdGkiOiJEYXNoYm9hcmRfRGVtbyIsInVzciI6ImJyZW5kYW5oZXl1In0._ktjhDmlwREyD1LEfPbh3D82XrWBjUGCd5feRAGcs6A

Thanks folks!
Brendan


#2

Actually - you know what? I found it.

Go to the “Access Tokens” menu. You have to manually create permissions for your buckets. Add a new permission and you are done!

Thanks Brendan! (lol)


#3

HI @brendanheyu, your approach was correct. However, you can do it automatically if you disable and re-enable the dashboard sharing again. It will add the appropriate required resources to the token. It is not done by default for security reasons. This is actually covered in documentation:

Note: If you change your dashboards by adding new data sources (devices or buckets), it is necessary to disable an re-enable the dashboard sharing to update the authorization. It will not share new data sources automatically for security reasons.

http://docs.thinger.io/console/#dashboards-share-dashboard

Best!