Problem with ESP8266AT


Im trying to get my esp8266 to connect to the thinger cloud. The device connects to my wifi but it cant connect to When I ping the address it resolve the ip, I’ve tried also using my phone but the same happens. Also, it defaults to run without TLS/SSL.

I’m using and arduino uno to talk with my esp chip. Heres my code and the debug console:

(Cant paste my code and log because “new users cant only post max 2 links”)

thanks in advance for any help!

I honestly dont know what I did, I tried a lot of old versions. I retried a lot of them and now it just works. I had my project code which I havent changed, that somehow works now… But I still cant get the TLS/SSL to work. I forced it to be on by changing the ESP8266AT.h file. It connects fine but then it says authentication failed.

Hello @MyNameIsSimon,

When having connection problems, remember to add the next code line at the top of your sketch and create a serial port in order to check the connection traze: #define _DEBUG_


Sorry I missed your reply. But after some tinkering I found out that the AT library doesn’t support SSL. So I switched to flashing the ESP8266 with my arduino, which also took some tinkering because there are so many versions of the board. The ESP8266 library is broken tho, I had to comment out a line to make it work. But other than that I like Needs some polishing but overall very fun to work with.