Node "edit bucket read node" in node-red does not work well


The node “edit bucket read node” is not working well at all in Node-Red.

At the image, we can see that “debug1” is shown (in red at the image), so the next step is into the node “edit bucket read node” , but the “debug2” is not shown (in green color). So, something is wrong in that node.

The node “edit bucket read node” in green and the node “edit bucket read node” in yellow are the same (they are a copy). If I trigger the yellow node, it works well (we can see the “debug4”), but as we can see, the green node is no working well:

The last data obtained in data bucket was on 19/04/2024:

Into the node “edit bucket read node” we have:

This data bucket is just for one device, so there is just one deveui and one devicename.

Maybe is that when the node read the data bucket, is just looking for in the last X hours?

Help please!

Thank you in advance,

Best regards,

Hello @EBA

After a quick search through your instance logs its seems that the Node-RED plugin is restarting when a message is received in that flow, likely due to a memory limit. You can check the logs of the plugin in the logs tab:

Given that the auxiliary flow (yellow) works for you, the fault either seems to be to the message entering the green bucket read node, or an infinite loop after the response of that node. Try to isolate it by disconnecting the output of the green node to any other nodes besides the debug. If its still failling analyze the entry message and try to replicate the same through the yellow one.

Hello again!

I will add extra testing information about it.

I have tried the next:


(the next step, I have tried with “TagDeviceName” and “TagDevEUI” filled too)

However, it just appears the “debug 7”, not the “debug4”:

Thank you in advance!