MongoDB User Password


#1

Hello,

I have made the following changes in config file

“database” : {
“type” : “mongodb”,
“mongodb” : {
“host” : “localhost”,
“database” : “thinger”,
“username” : “PAdmin”,
“password” : “Padmin Password”
}
},

2018-04-27T07:09:30.515337 fatal [Server Manager] Thread (140081326016256) running error: OperationException: { ok: 0.0, errmsg: “not authorized on thinger to execute command { createIndexes: “refresh_tokens”, indexes: [ { name: “used_1”, key: { used: 1 }, expireAfterSeconds: 527…”, code: 13, codeName: “Unauthorized” }

I have also tried with
"user" : “PAdmin”,
“pwd” : “Padmin Password”

What are the correct settings?

Thanks

Roman


#2

Hi, the server does not support mongodb authentication at this moment.


#3

Hello,
I have the same problem without users configuration.
mongodb log:
[conn1] note: no users configured in admin.system.users, allowing localhost access
2018-05-11T18:12:42.251+0200 I ACCESS [conn1] Unauthorized: not authorized on thinger to execute command { createIndexes: “refresh_tokens”, indexes: [ { name: “used_1”, key: { used: 1 }, expireAfterSeconds: 5270400 } ] }

I tryed mongodb 3.4 and 3.6 versions.

Where is my fault?
tks,
J.J.


#4

Solved,
it is sufficient commenting the “Security settings” in the file mongo.conf.