MKR1000 won't connect to thinner.io


#1

I have installed many libraries, watched all the tutorials, read at least 10 forums and I cannot get my MKR1000 to connect to Wifi or Thinger.io. I have tried using my phone as a hotspot and that does not work also. I have added thinger.io:443 as a wifi domain, updated the firmware, and this is the code I am using. Any help would be appreciate because I’m at a loss.

!


#2

Hello @alicebabashak,

Welcome to our community, and don’t worry, sure that with some indications we can solve your problem!

I’m seeing that you have included the debug command. Can you show us the connection trace in the Arduino Serial Monitor?
Maybe the problem is related to the SSL certificate. Have you tried upgrading it? IF you didn’t, I’m sure that this is the problem, but if after that the problem persists you can also try two more things:

1-disable the security protocol by including: #define _DISABLE_TLS_
2-Trying with an old Thinger.io library version

Hope it helps!


#3

Hey, I have updated the SSL certificate every time and added the thinger.io:443 domain, I believe the problem is that my university’s internet will not let the chip have access to the wifi. I’ve tried using my phone as a hotspot but it does not have a strong enough connection