Missing data points in time series chart - Community

Hi, I’m testing ThingerIO with free Community plan.
Data buckets correctly save information, but dashboards keeps missing data points, showing only the first and latest ones. Is it a limitation of the free plan?


The limitations on the freemium server are the amount of devices (2) and the refresh rate (up to 1 minute minimum),

Check at the bucket if truly there are data in the missing points lapse, bc it seems as there is no data.

Hope this helps.

Two devices, two databuckets and one dashboard are present in my ThingerIO account.
Only one device is sending data. It transmits over LoRaWAN to The Things Network and from there data are correctly saved into a ThingerIO databucket.

Please see the linked data exported from the databucket (some columns were redacted for publishing):

Here are my stats:

Thanks in advance for any hint around this topic.

Same data bucket, now:

Will take a look at that today. Do you have an example of the data that is being sent to the bucket? i.e., the configuration on The Things Network?

Here’s my The Things Network webhook.

As you can see at the link in my 2nd post data bucket is filling as expected.

Can I provide any useful information?

TheThingsNetwork is uploading correctly to ThingerIO data bucket, but I still get buggy data visualization with time series widgets even with a new dashboard.

Below you can find a chart generated from the same data bucket, last 20 days exported.

Solved in the 5.1.8 version that will be updated today.

The problem is that you are storing too much information in each bucket entry. The community version is based on DynamoDB which limits the maximum data processed per query (1MB). You were reaching this limit easily when requesting data from this dashboard, which queries a maximum of 1000 chunks per query. We have reduced the chunk size so it is affordable for DynamoDB.

However, you will see that your dashboard will take a lot of time to load and print since you are plotting thousands of data points. I suggest reducing the chart timespan or reducing the sampling interval in your devices.

Another alternative is to use a private server instance that uses InfluxDB that can provide data that is aggregated, i.e., using a mean.

Will post again here when the new version is available.

1 Like

It should be working in your account right now! Thanks for the report.


Thanks for the solution and for the clear explanation too.

1 Like

I can confirm that my PoC dashboard above is now working perfectly.

Thank you!