Is Server Down/?

Is Server Down?
I cant connect with 2 different esp8266…

I can connect them fine, what is the problem? Can you access the console?

I can access the console but device is disconnected.I see the blue light flashing every few seconds like its trying to connect but nothing happens…I checked the router and the programm many times…

Uhm check the ESP8266 example sketch you used. Maybe you have selected the ESP8266SmartConfig, which requires additional configuration through mobile phone. It is the only one sketch that flash the led. Try loading the ESP8266 sketch.

i use the esp8266-12 .i did what you sugested but nothing happens

Please, compile your sketch with debug active, so we can see what is happening in the execution, as the Led should not blink. Check this page for enabling debug in the sketch. And get the output from the Serial Monitor to see what is happening.

I suppose you have changed the WiFi SSID, Wifi Password, device ID, and device password in the sketch, right? Do you have a protected WiFi? WPA/WPA2?


I have checked everything. i could connect on friday but i tried today and i cant.i tested different router with different connections but still nothing so i assumed if there was a problem with the server…

Good to have more details about your problem! Didn’t know you have access previously… Tell us all details you have when asking, so we can both save time! :slight_smile:

I have restarted the server to see if there was some problem with it. I have all my devices connected again… Did it changed something for you?

still nothing. I will check later with another esp and i will let you know.
thanks for the quick response

OK! Did you tested with the DEBUG option to see where is the problem? To see if they are sticking at Wifi connection, or they have some problem reaching the server? Or the modules are not working properly and the debug option is no reporting anything…

So this time i tried the esp8266-01 and still got no connection.I did the Debug but still not getting something that could help…It is hard to believe that both esp are suddendly damaged…

Also the debug returns the following :

ets Jan 8 2013,rst cause:4, boot mode:(3,7)

wdt reset
load 0x4010f000, len 1264, room 16
tail 0
chksum 0x42
csum 0x42

This is quite strange!

I have tested with the latest ESP8266 library: 2.2.0
Latest library: 2.3.1
Arduino Version: 1.6.9
Hardware: NodeMCU 1.0

My log result is:

[NETWORK] Starting connection...
[NETWORK] Connecting to network Meeble
[NETWORK] Connected to WiFi!
[NETWORK] Getting IP Address...
[NETWORK] Got IP Address: Meeble
[NETWORK] Connected!
[_SOCKET] Connecting to
[_SOCKET] Connected!
[THINGER] Authenticating. User: alvarolb Device: nodemcu2
[THINGER] Writing bytes: 37 [OK]
[THINGER] Authenticated

Did you remember any changes in your build environment? Your hardware connections? Your power supply? Pull-ups or pulldowns? Or anything else?.

The reboot reason you are getting seems to be related with `REASON_SOFT_RESTART`, so your device is being reseted by software... Maybe a watchdog is firing a restart..

I found two different posts that may be related with your problem, check it out:

I remembered that you got a blink led while trying to connect the ESP8266, that is exactly the soft reset resetting the device every time. Check using a stock example from the ESP8266, like WebClient or something similar to see if you got results.

Finally both esp were able to connect…i didn’t change anything i just kept uploading my code since the Debug didn’t give any answers…
I still believe that something was wrong with the server that i cannot explain.
Thank you very muxh for your fast responces.

Good! you have now them working! However I don’t think it was a server problem, as it has been working several months without problems, and even after the server restart you had the same problems. And the blinking led was caused by a soft reset, may be fired by a timeout while acquiring ip address, doing a DNS resolution, or anything else. Anyway you have them working now!