I cannot connect to thinger.io


today I have migrated a program initially written for the ESP8266 to an ESP32.

I cannot connect to thinger.io.

Here is the log:

17:22:01.973 -> [_SOCKET] Connecting to iot.thinger.io:25202...
17:22:01.973 -> [_SOCKET] Using secure TLS/SSL connection: yes
17:22:02.821 -> [_SOCKET] Connected!
17:22:02.821 -> [THINGER] Authenticating. User: RIN67631 Device: JuntekNT
17:22:02.868 -> [THINGER] Writing bytes: 43 [OK]
17:22:02.868 -> [THINGER] Auth Failed! Check username, device id, or device credentials.
17:22:02.868 -> [_SOCKET] Is now closed!

The device JuntekNT exists for the user RIN67631 and the credentials are correct.

Any idea where to search, why it does not connect?

The code is straight forward:
#include <ThingerESP32.h>

If in setup(), I connect with thing.addWiFi or with my own WiFi connection method does not change anything.
I still get the same error.

I suppose the THINGER_DEVICE is still the name of the device in the device list and not the new device names, OK?

I have additional information:
I have supplied exactly the same device and login information to an existing ESP8266 sketch, that I use daily on many devices and got the same error behaviour.

It does not look as it were linked to the ESP32device, but looks very likely to be a hickup at the new Thinger version that interprets the device in fo like it should not.

Hi @rin67630, I think the problem is your username, it should be rin67631 instead of RIN67631.

1 Like

Maybe it is an error introduced with your second Thinger.io community account :wink:

Shame on me!
I need the week-end, Why did I make a such stupid mistake?
Thank you for your kind assistance.