Help not able to connect thinger.io server - ardiuno+sim800module


#1

hello,
i been trying to connect gsm module to thinger.io server but it is not connecting. i read all the possible information regarding the same and make some changes accordingly and also i am new to this cloud please help me with the steps.


#2

Hi,

can you please enable the log output and paste here the result?

Best.


#3

ok this is output shown on serial monitor

[NETWORK] Initializing Modem…
[NETWORK] Cannot init modem! Is it connected?
[NETWORK] Cannot connect!

and i have tried this coad:-
#define TINY_GSM_MODEM_SIM800
#define DEBUG
#include <TinyGsmClient.h>
#include <ThingerTinyGSM.h>
#ifndef HAVE_HWSERIAL1
#include “SoftwareSerial.h”
SoftwareSerial Serial1(2, 3);// RX, TX for gsm
SoftwareSerial Serial2(4,5);// RX, TX for ultasonic
#endif

#define USERNAME “******"
#define DEVICE_ID ""
#define DEVICE_CREDENTIAL "

// use your own APN config
#define APN_NAME “airtelgprs.com
#define APN_USER “”
#define APN_PSWD “”

// set your cad pin (optional)
//#define CARD_PIN “”

ThingerTinyGSM thing(USERNAME, DEVICE_ID, DEVICE_CREDENTIAL, Serial1);

void setup() {
// uncomment line for debug
Serial.begin(9600);

// Serial for AT commands (can be higher with HW Serial, or even lower in SW Serial)
Serial1.begin(9600);
Serial2.begin(9600);
pinMode(4, OUTPUT);
pinMode(5, INPUT);

// set APN (you can remove user and password from call if your apn does not require them)
thing.setAPN(APN_NAME, APN_USER, APN_PSWD);

// set PIN (optional)
// thing.setPin(CARD_PIN);

// resource input example (i.e, controlling a digitalPin);
//pinMode(13, OUTPUT);
//thing[“led”] << digitalPin(13);

// resource output example (i.e. reading a sensor value)
thing[“SONIC”] >> [] (pson& out){
double duration, distance;
digitalWrite(4, LOW); // Get Start
delayMicroseconds(2); // stable the line
digitalWrite(4, HIGH); // sending 10 us pulse
delayMicroseconds(10); // delay
digitalWrite(4, LOW); // after sending pulse wating to receive signals
duration = pulseIn(5, HIGH); // calculating time
distance = (duration/2) / 29.1; // single path
out = distance;
// Serial.print("Distance: ");
// Serial.println(distance);
};
}
// more details at http://docs.thinger.io/arduino/

void loop() {
thing.handle();
}


#4

This module is a little bit particular,

Do you feed it with max 4.2 v? because if you feed it with more than that it can be burned.

It drains a lot of current when connects (according datasheet near 2A), can the power supply give it?

Which is the behavior of the on board led?

I dont remember it default serial baud rate, but I always use 57600, and I have had issues with software serial (with other module, not this particular), so I recommend to use hw serial port when it is possible.

The issue is directly with communication between your board (by the way, which one are you using?) and the GSM module, not with the cloud service.


#5

ok first about the power supply i am giving power through dc socket so it is providing enough power.

i am assuming you are talking about led on the gsm module. yes it is blinking accordingly i.e long off shot on.

ok now about communication i have tested gsm module with same port by giving AT command and as well as sending message to another number with baud rate 9600 and it works perfectly.

i’ll try to use hw serial port and make some changes in the code.


#6

I had some problems with the connection when using the latest library and sim 808. In my case i just downgraded the library to a earlier version and it worked fine after that :slight_smile: