Error with ArduinoEthernet example

Hello everyone, I am asking for your help with the following.
I am trying to use the ArduinoEthernet example to connect to thinger but I get the following error.

I am using arduino UNO or Arduino Ethernet

Thanks in advance!

c:\Users\diego\Documents\Arduino\libraries\\src/ThingerClient.h:546:27: note: suggested alternative: 'set_state_listener'
         state_listener_ = state_listener;


Which development IDE are you using and Thinger’s library version?

I guess this could be sorted downgrading the thinger’s library, maybe the 2.17 version (or so) could work fine with your setup (Arduino Uno + Eth Shield).

Let us know how it goes.

Hello ega, in theory, I have the latest updates to the thinger libraries, I have also tried several versions of Arduino, including 1.8.19 and the same thing happens.


I meant the thinger’s library, try with the previous ones, I would recommend to test the 2.17.


I just tried this:
Arduino IDE 2.3.2
Thinger library 2.17 - ArduinoEthernet example

and it did not compile for the Arduino UNO due lack of memory, I share the IDE error:

Sketch uses 26016 bytes (80%) of program storage space. Maximum is 32256 bytes.
Global variables use 2685 bytes (131%) of dynamic memory, leaving -637 bytes for local variables. Maximum is 2048 bytes.
Not enough memory; see for tips on reducing your footprint.
data section exceeds available space in board

Compilation error: data section exceeds available space in board

However it compiled successfully for Arduino Mega 2560

Sketch uses 26948 bytes (10%) of program storage space. Maximum is 253952 bytes.
Global variables use 2713 bytes (33%) of dynamic memory, leaving 5479 bytes for local variables. Maximum is 8192 bytes.

Hope this helps.

Hello ega, the same thing happens with the arduino mega.
The errors that appear are not from memory, they are from some instances of the thinger library.
Thank you!

Hi Diego,

You need to install the thinger library version 2.17, version 2.26 will not compile this example.

Note that I have 2.17 version installed and it compiled successfully

I would not use an Arduino with Ethernet these days. Instead, I would prefer an ESP32 variant, like this one from Olimex, that even supports PoE. I have one of these connected to the platform for several months now.

1 Like

Hello gea, this works as you say, with the Thinger 2.17 library and on an arduino Mega
Thank you very much for your help.

Hello, it happens that a client specifically wants to connect the module via Ethernet, because there is no Wi-Fi network and they only have a specific router to connect it to.

The ESP32 board I posted from Olimex has Ethernet.