Error 400 on Data Bucket Creation

Hi all, I am attempting to create a data bucket but am getting this error (see picture): “Ooops! Cannot process your request. Error 400 (failed to validate request schema)”

All the required sections are highlighted green, and this is only the second data bucket I’m trying to setup. I set up my first data bucket a few months ago with no issues; I also tried editing that one as a test but I get the same error.

This is how I have my resources set up in my code:

thing["severe fault codes"] >> [](pson& out) { out = fault_code_severe; };
thing["mild fault codes"] >> [](pson& out) { out = fault_code_mild; };
thing["status text"] >> [](pson& out) { out = status_text; };
thing["test index text"] >> [](pson& out) { out = test_index_text; };
thing["current test time rem"] >> [](pson& out) { out = curr_test_time_text; };
thing["total test time rem"] >> [](pson& out) { out = total_test_time_text; };

thing["numerical data"] >> [](pson& out)
    out["pressure 1 real"] = getDataVal(PRESSURE_1_REAL, -1, 0);
    out["pressure 1 target"] = getDataVal(PRESSURE_1_TARGET, -1, 0);
    out["pressure 2 real"] = getDataVal(PRESSURE_2_REAL, -1, 0);
    out["pressure 2 target"] = getDataVal(PRESSURE_2_TARGET, -1, 0);
    out["temp 1 real"] = getDataVal(TEMP_1_REAL, -1, 0);
    out["temp 2 real"] = getDataVal(TEMP_2_REAL, -1, 0);
    out["motor 1 RPM"] = getDataVal(MOTOR_1_TARGET, -1, 0);
    out["motor 2 RPM"] = getDataVal(MOTOR_2_TARGET, -1, 0);


All the data in each of those resources shows in the dashboard for this project with no issue, so it seems like my code should be fine.

Has anyone experienced this before? Not sure what else to try here.

I had a similar issue a while ago, when I check and uncheck something from theh advanced options, but just cancelling that and creating the bucket without usingt the advanced options worked just fine, i dont know if is the same issue.

Thanks for the suggestion, I tried that but unfortunately I got the same error. I was able to eventually make the bucket, but I had to switch the data source to “From Device Write Call” and update my program to stream “numerical data” once every minute. This is pretty strange though since all the widgets on the dashboard for this device use “From Device Resource” with no issues. The data bucket seems to not like accessing “numerical data” by itself for some reason, maybe it has too many data points?