Connection Issue to with ESP32

Hello world !

I beg your pardon for my English…

I’ve been having a connection issue to the server with all of my esp32’s (and esp8266’s) for several months.

The situation :
I am installing a system working on an esp32 in a public building (high school). I set up an access point plugged in the school network and it worked well with my computer - theoretically the ports 25200 and 25202 should be open. Nevertheless, my esp32’s cannot connect to the cloud server (no problem with username, device_ID, credential, SSID or password).
I tried with a simple sketch (ESP32.ino from examples of the library) with and without TLS, but it did not work.
I tried to set up the access point at home and it worked well (without TLS), same thing with my router at home.

The first capture below shows the connection debugging message without TLS (#define _DISABLE_TLS_) :

and the second one with TLS :

If anyone has an idea of what’s going on please let me know


Your english is good,

The issue is so weird, the example sketch should work smoothly.

I would recommend you to check your software versions, sometimes the last versions arent compatible between them, I mean, for example the last version of the ESP32 controller boards, is not compatible with the TLS support (dont know if its already patched, there is a topic that refers to this).

In any case, I will share with you the versions that I have installed, in order you try to get the same and try again the connection

I have:
Arduino IDE 1.8.12 (maybe the last version of this one is not a big deal)
ESP32 1.0.4 controller board 2.15.0 Library

With those the devices connects with no issues, with and without TSL.

Hope this helps.


Thank you for responding so quickly

I just tried according to your recommendations, but it did not work with TLS :

Erreur esp32 TpLink ide_1_8_12 esp32_1_0_4 thinger_2_15_0 TLS_SSL_yes

And without TLS, it is the same : [_SOCKET] Error while connecting!

You are right, @ega, the issue is very weird considering this fact : it work very well at home, but do not work with the school network… Is there a special security in public network that I omitted ?

Thank you in advance for the help provided.

Ok if it works at other place but it does not work there, the issue is with the network, I mean, the access, maybe the network has a block to those specific ports, but the fact that it connects from other network establishes that the issue is not with the device and the platform, but with the access.

I tried with a connection-sharing and it did work too, with and without TLS. But at home it works well with and without TLS.

Hi this seem to be the known TLS issue.
Please revert to version below 2.15.0
2.14.0 runs well here.
The version 2.16.0 of looks to have problems with a secure connection; the old versions run fine.

Thank you ! I will try this version asap.