Can't Connect to Thinger Platform using a Power Bank connected to Nano 33 IoT board


I’ve been using the Nano 33 IoT board for almost a month. I managed to connect it to the thinger platform and I was able to read data there based on my code. However, I tried to use an external power source rather than a PC or a laptop. In my case, I tried using a power bank. So when I uploaded the code to the board and connected the wire to the power bank, there was no connection to the platform. I would be very thankful if anyone can help me in this issue.


Just as you are presenting us with the problem, the irregularity is with the power bank, it is strange because I suppose it handles enough voltage and current to turn on the microcontroller, but if the only thing that is being changed is the power source, the irregularity is in that stage, please verify cables and other components involved in it, the fault is not a code or configuration.

Does the micro turn on any led? I am sorry but I have not worked with that micro, I would try to test by turning on some led to verify that it actually works with the power bank.

I’ve made work an NodeMCU with a powerbank too, with no issues.