Arduino + Wifi - Shield socket problem


#1

Hey guys,
tried to use a Arduino + Wifi to conect to the cloud. I used the script as it is shown in the documentation but i got the following socket problem:

[NETWORK] Starting connection…
[NETWORK] Connecting to network ArduinoTEST
[NETWORK] Connected to WiFi!
[NETWORK] Getting IP Address…
[NETWORK] Got IP Address: 192.168.1.100
[NETWORK] Connected!
[_SOCKET] Connecting to iot.thinger.io:25200
[_SOCKET] Using secure TLS/SSL connection: no
[_SOCKET] Connecte
5- Q- QuoConnecting to iot.thinger.io:25200
[_SOCKET] Using secure TLS/SSL connection: no

The script I used:

#define THINGER_STATIC_MEMORY_SIZE 512

#include <SPI.h>
#include <WiFi.h>
#include <ThingerWifi.h>

#define USERNAME “OURUSERNAME”
#define DEVICE_ID “OURDEVICEID”
#define DEVICE_CREDENTIAL “OURCREDENTIALS”

#define SSID “ArduinoTEST”
#define SSID_PASSWORD “ArduinoPasswort”

ThingerWifi thing(USERNAME, DEVICE_ID, DEVICE_CREDENTIAL);

void setup() {
Serial.begin(9600);

// configure wifi network
thing.add_wifi(SSID, SSID_PASSWORD);

}

void loop() {

thing.handle();
}

I think it might be a DNS problem because i tried multiple networks and other devices on this networks worked perfectly fine. I would be happy about any ideas or help.


#2

We found out that the WiFi shield of our arduino had some unkown problems, so we tried it with an ethernet shield and everything was pefectly fine.


#3

Hi @ipprdmt, take a look to this post, as we had also some problems with the Wifi shield, that were resolved using static memory allocation.

I think that you are missing the #define THINGER_USE_STATIC_MEMORY at the beginning.


#4

No doubt a few more niggles and problems will arise as people start to use the phones, so let us know if you’ve found anything specific you need help with.