Strange SSL certificate error in endpoints

Dear community,

i’ve a strange problem with http"s" calls in endpoints.
If i call a website with LetsEncryt certificates, i’ve got on some websites an “Error 500 (certificate verify failed)”. For example on https://ittb.info. When in call website of LetsEncrypt itself there is no error.
Both sites uses regular LetsEncrypt certificates, both sites are green in every browser and both sites do have the same certificate-path with same root authority.
This problem is thinger.io and my local thinger server.

Does anybody know about this issue? Is there a chance to see in any logs what happend in detail?

Regards Marcel

Hi, yes, there is a problem with such certificates in the current version. We have a private version with a fix, but it has not been released yet, as we are so busy preparing a major release, so, stay tuned :wink:

Hello, I have same problem here.
if there any ETA about the next release?
Thank you so much for this amazing platform!
Regards.

Hello @thespacesiddhesh,

Thank you very much for your kind words. Actually the next release is ready right now, but only in the private instances. The community server update will delay a little more, there is not an estimation yet.

Best!

Hi,
I have a VPS using thingerio and got HSTS (HTTP Strict Transport Security) warning issue with almost all browser( Chrome, Firefox, IE, etc). In early 2019 i’ve bought an SSL certificate but still failed to install on my thingerio VPS.
Could you tell us when the next release of private version is updated? @alvarolb

PS: i also attached the HSTS warning issue for your refference.