(Cannot process your request) I can't access to data bucket or device that I already create

Today while working on my project, I discovered that I couldn’t access the api that I had created, so I went to look at the issue. io displays this error to me.

Cannot process your request
Error (-1): connection not available


Could you provide a little bit more details, as the instance (private or community server)? in order to aim the effort to check directly where the issue is.

If it is at the community server I would try again, as there were reported some issues related this service but currently it is working as expected.

Hope this helps.

I’m kinda confused about your question on private or community servers. Could you clarify it for me?

So, I’m having this issue where I can’t get to any stuff I made on thinger.io, like devices, databuckets, and tokens. Even when I try to make new devices or databuckets, I just get the same error.

Yes sure, can you share the address you are accessing to? to use it as example.

It seems like the error only happen in some countries (at least in SEA the error still there). I got the same error, tried to use VPN, and the error is kinda solved (still can’t connect my device tho lol).

https://console.thinger.io/ here my address that I accessed. not sure if this address that you mean lol.

Ah, got it! I live in a Southeast Asian country too. Thanks for the info! :smiley:

This is the public community server.

I guess it could be an issue with the redirection as the community service is served by a cluster, so according your location it redirects to your closer instance, maybe a workaround could be to detect the address of the service that serves your location, by a nslookup to iot.thinger.io or backend.thinger.io, in my case it aims to us-east.aws.thinger.io


Hope this helps

1 Like

Thanks! But how does my device connect to thinger.io? Should I wait for fix since I’m living in SEA?

Yes, the VPN allows the browser to try connection from other location, but not the device, that is why, maybe the previous workaround allow it to reach the service but you will need to flash the devices again.

I would wait until they solve officially this, for sure it wont take so long.

You can flash it with that address, or wait until they solve it, if you choose to re-flash it changing the address I would recommend to get that change back the when the issue is solved.

1 Like

Thanks so much, that was really helpful! :smiley:

You are welcome :wink::+1:t2: